load JOSM-created osm file fails

May 26, 2012 at 4:42 PM

I have an osm file created by JOSM, and when I attempt to load it into a geodatabase using the Load OSM File tool, the tool churns for awhile and then fails; no feature dataset is created. Any ideas?

May 26, 2012 at 9:52 PM

Depends on the error message. Do you get one?

If the file isn't too big could you please post it and we'll run the process through a debug session and watch for issues?



- Thomas

May 28, 2012 at 1:26 AM


I tried several times more and finally got it to run...we'll have to assume operator error for now...I think perhaps I was not specifying the Feature Dataset correctly in the tool window. For future reference, how do I post a file -- my file was 17000 lines -- just copy/paste to this edit window?


May 28, 2012 at 6:10 AM


When you create an issue (http://esriosmeditor.codeplex.com/WorkItem/Create) you have the ability to add attachements of up to 4MB. If your file (even when zipped) is larger than that, please tell us the steps to reproduce the issue (maybe some filtering with osmosis or the like), and we'll try to match your settings in size.

Glad it's working for you now,

- Thomas

Dec 14, 2012 at 8:51 PM

I have the problem with loading my *.OSM to arcgis 10.1 by "load osm file". I did several times in different ways but always i faced with the same error that:  the tool is not valid.

Executing: OSMGPFileLoader C:\Users\M\Desktop\Seminar\test\map.osm CONSERVE_MEMORY C:\Users\M\Desktop\Seminar\test\test.gdb\OSM_München1 C:\Users\M\Desktop\Seminar\test\test.gdb\OSM_München1\OSM_München1_osm_pt C:\Users\M\Desktop\Seminar\test\test.gdb\OSM_München1\OSM_München1_osm_ln C:\Users\M\Desktop\Seminar\test\test.gdb\OSM_München1\OSM_München1_osm_ply
Start Time: Fri Dec 14 22:48:19 2012
ERROR 000816: The tool is not valid.
Failed to execute (OSMGPFileLoader).
Failed at Fri Dec 14 22:48:19 2012 (Elapsed Time: 0,00 seconds)

I´m using Arcgis 10.1 and ArcGIS_Editor_for_OSM_2_1_Desktop_Beta3.

Do you have any idea about this problem?

I appreciate your advice in advance.


Dec 14, 2012 at 10:35 PM

Hello Mandana,

A couple of things -

1) Do you happen to have ArcGIS 10.1 64bit background geoprocessing installed?  If so, then you will need to uninstall your current version of ArcGIS Editor for OSM and download the latest released package - our final release, available at http://esriosmeditor.codeplex.com/releases/view/98978. This includes an installer for ArcGIS Editor for OSM that is specific for the 10.1 64bit background geoprocessing environment. The installer is called "ArcGIS_Editor_OSM_10_1Desktop_64_BackgroundGP"; you should see it when you unzip the file.

2) As stated in #1, we do have a new release, and so you should use this final release instead of Desktop Beta 3. Again, you will have to uninstall the ArcGIS Editor for OSM Beta 3 and install the new version.  The final released version addressed some issues in the Beta 3, so its the one you want to use.

Let us know if this helps!


Dec 14, 2012 at 11:15 PM

Dear Christine,

Thanks so much for your great help.

As you guess I have ArcGIS 10.1 64bit background geoprocessing installed on my system. And now with your useful advice the tool works properly.


Best regards,


Dec 14, 2012 at 11:26 PM

Mandana, I'm so glad to hear that it is working for you now!  Thanks for letting us know. Have a good weekend!