Uploads without error, no changes visible in OSM

Apr 27, 2012 at 6:16 PM

I'm new to using the OSM editor (but not new to ArcGIS). Everything seemed to work in ArcMap as described in the documentation when I downloaded OSM data, made edits, and submitted them to the OSM server. However, nothing is showing up in my OSM account (list of edits) or on OSM. It's as if nothing was sent. The OSM upload didn't encounter any errors. Message from tool below:

Messages
Executing: OSMGPUpload http://www.openstreetmap.org C:\Users\Eric\Documents\ArcGIS\Default.gdb\OSM2_osm_revision "Improved Rock River bank between 106 and 12 using 18 inch imagery from 2010" OSMCHANGE_FORMAT ""
Start Time: Fri Apr 27 09:52:56 2012
Opened changeset 11433333.
Submitting 1 features to the server...
Reconciling local data with server information.
Closed changeset 11433333.
Succeeded at Fri Apr 27 09:53:00 2012 (Elapsed Time: 4.00 seconds)

Thanks for any help with using the tools. I teach GIS and am hoping to have my students contribute to OSM using ESRI's tool.

Dr. Eric Compas
UW-Whitewater

Apr 29, 2012 at 1:25 AM

Did a bit more looking and found the URL to view a changeset. Here's mine that was made above: http://www.openstreetmap.org/browse/changeset/11433333

Looking at the changeset XML, none of the edits I made were included -- nothing sent to the OSM server? Is this a bug the OpenStreetMap editor or a problem in how I've configured it or am uploading data?

Eric

Coordinator
Apr 30, 2012 at 2:46 PM

Hello Eric,

It doesn't sound like you did anything wrong - I saw your changeset on Friday and sent it to our dev team to look into.  Will post as soon as they look at it.  Let me verify your workflow here: 1) Use Download, Extract, & Symbolize tool to download data to OSM. 2) Made edits to that dataset. 3) Use Upload to OSM tool to post back. Is that correct?

A question - did you add any columns or use 'append' to add any data to your dataset?  

Many thanks,

Christine

Developer
Apr 30, 2012 at 4:40 PM

Hi Eric,

Can you please check your C:\Users\Eric\Documents\ArcGIS\Default.gdb\OSM2_osm_revision table.  This is the table that tracks all the edits and lets our app know what to send to the OSM server.  If there are no rows in this table, then we know the issue lies somewhere in the edit process, otherwise it may be in the  upload.  Either way, knowing the contents of the revision table will help us determine the problem.

Thanks,

-Greg

May 1, 2012 at 5:43 PM

Christine,

Yes, that's the workflow I used. My edits were limited to modifying existing lines (river banks) and adding a couple of points (based on air photo locations). I didn't "append" any data and did not modify any columns in the feature tables.

Greg, I've verified that the OSM2_osm_revision table is in the geodatabase (here's a screen capture -- note the geodatabase was moved from it's original path after I uploaded) and that it contains rows (168 edits).

Let me know if you need anything else to troubleshoot.

Thanks,

Eric

Coordinator
May 1, 2012 at 8:45 PM

Hello Eric,

Thanks for providing the screen capture.  When we look at the revision table, we see that there is no data for the OBJECTID == 4 row.  We will need to dig to figure out how that happened, but suspect that having no data could be why the Upload OSM Tool didn't complete correctly.

If you delete that row in the revision table and attempt to Upload again, do the edits get uploaded to OSM?

Christine

May 2, 2012 at 1:53 PM

Tried to delete this row, but ArcMap crashed repeatedly when starting an edit session (running SP4). So, I wasn't able to retry the Upload on this particular revision table. I'll be trying another set of edits today and will look for a blank line in the revision table before attempting to Upload.

Eric

May 2, 2012 at 8:37 PM

Repeated the same edits twice. First time ArcMap crashed on the Upload -- nothing showed up on the OSM server and nothing left to debug. Revision table was empty when I reopened it. Second time, everything worked and the upload successfully sent changes to the server (http://www.openstreetmap.org/browse/changeset/11483204). Didn't do anything different between the two procedures. So, nothing useful for replicating or debugging the error above.

Eric

Coordinator
May 3, 2012 at 12:05 AM

Hello Eric,

Sorry to hear about the crashing, but glad that it was finally successful.  Now to hunt down the details. A question about your second - and successful - attempt: did you delete any rows from the revision table before uploading, or did it just work?  I do see your changeset, and that its the same location as where you were working before. The same type of edits too, right?

Thanks for continuing to help us figure out what's going wrong.

Christine

May 23, 2012 at 8:02 PM
Edited May 24, 2012 at 4:29 PM

I believe I'm experiencing something similar to this. I've made a very basic edit, adding genus=pinus + species=radiata to this natural=tree http://www.openstreetmap.org/browse/node/1763246414 I uploaded without error but the data was not sent to the OSM Server. Also, I don't see the changes in <name_of_featuredataset>_osm_revision BUT if I turn Editing back-on, Select the point with the Edit tool > right-click > Attributes - - I can still see the tags I added.

EDIT* starting over with a new .gdb and feature class + doing the same exact thing, a second time - was successful like @geographer's experience above.

Coordinator
May 29, 2012 at 9:37 PM

Hello Jlar,

Thanks for reporting your experience. We will look into this; its odd (and disconcerting!) that the behavior is not consistent. We may have some further questions as we investigate.

Christine