upload data behind a proxy

Mar 29, 2012 at 9:36 AM

Hello,

I'm trying this extension for a few days.

I'm working behind a proxy.

I arrived to dowload OSM data.

But after I've modified them I can't upload them.

The erreur message said that an authorisation proxy is necessary.

Anybody has an idea ?

 

Thanx by advance.

Sylvain

Coordinator
Mar 29, 2012 at 5:43 PM

We will look into this... version 2.0 was enhanced to include working through a proxy. Stay tuned...

Developer
Apr 3, 2012 at 11:38 PM

Sylvain,

I retested the proxy parts of the code for uploads and downloads and they seem to be working as expected.  Can you give us a little more information about your error?  

Are you getting an HTTP: 407 error (Authentication Required)?  If so, can you go into ArcCatalog on your client machine and click 'ArcCatalog Options' from the menu.  On this dialog, you should see a Connections tab.  This should show the information about your proxy, including user name and password.  Does this all look correct for your environment.  I suspect your user name and password are not set here and that's why your authentication is failing.

Thanks,

-Greg

Apr 19, 2012 at 1:39 PM

I have the same problem.

I am using ArcGIS 10.0 SP4 and the OSM Editor 2.0 final. I can download and symbolize the OSM data, i can edit them. no problem at all.

When i try to upload the data to OSM the script runs also, no errorr messages whatsoever.. but the data has in fact not been uploaded to the OSM database. When checking the data via JOSM or Potlach it becomes apparent that the changes have not been written to the OSM-Database... 

what could be the problem?

I work behind a proxy as well.

Coordinator
Apr 19, 2012 at 4:18 PM

Hello cidomo,

Will you verify that you have set the Connections information, according to gdestigter's suggestion above?  To do this: 1) close any open ArcGIS desktop applications 2) Open ArcCatalog, go to the 'Customize' menu at the top, select the 'ArcCatalog Options' menu, and once there go to the Connections tab, 3) on the connections tab, fill out the information for your proxy authentication, 4)  Now you can open ArcMap and work, and the proxy info from ArcCatalog will be persisted in ArcMap too.

If you set the proxy in ArcCatalog and still see the issues, please let us know.

- Christine

Apr 23, 2012 at 3:25 AM

Dear Christine...

hmm it seems its not the proxy. I also tried it with a different internet connection (that is not behind a proxy) and still... everything seems to work fine, no error messages or warnings, just the data seems to get not into the OSM Database... 

I also tried from a different computer... same issue... difficult to tell whats wrong cos no indicators of whats wrong.. does no one else had this problem?

 

 

 

Coordinator
Apr 23, 2012 at 4:36 PM

Hello cidomo,

Will you please try your workflow again, and then when you get to the step where you use the Upload OSM Data tool, make sure you uncheck the "bundle data upload" option? We don't expect this to fix the behavior, but what it will do is reveal better error messages in your revision table.  After the Upload OSM Data tool completes, will you send us a copy of the revision table?

Many thanks,

Christine

Apr 30, 2012 at 11:40 AM

Hello.

Excuse me but my computer was down since yesterday.

 

So, I try againthe process without success.

 

In the options of ArcCatalog my proxy is configured.

In ArcMap I arrived to load  maps from ArcGis.com, so I think the proxy is correctly configured.

I haven't the error HTTP: 407 error (Authentication Required).

I've a warning message for a timeout, butthe main message is success (in French below) :

Messages
Exécution de : OSMGPUpload http://www.openstreetmap.org D:\OSM\OSM.gdb\test_osm_revision test OSMCHANGE_FORMAT ""
Heure de début : Mon Apr 30 13:28:52 2012
Le délai d'attente de l'opération a expiré.
Opened changeset 11458943.
Submitting 1 features to the server...
Reconciling local data with server information.
réussie à Mon Apr 30 13:29:08 2012 (temps écoulé : 16.00 secondes)

Thanx for your help.

 

Sylvain

Coordinator
Apr 30, 2012 at 8:56 PM

Hello Sylvain,

Thanks for attempting the workflow with your proxy set in ArcCatalog. We would like to investigate further - as you can see, another user above had a similar issue too, and we have requested that he/she try the workflow again, but  when you get to the step where you use the 'Upload OSM Data' tool, make sure you uncheck the "bundle data upload" option. Then after the 'Upload OSM Data' tool completes, will you send us a copy of the revision table?

Many thanks,

Christine

May 2, 2012 at 9:50 AM

Hello,

I retry the operation and I uncheck the "bundle data upload" option.

I've the same issue.

How can I send you the revision table ?

Sylvain

Coordinator
May 3, 2012 at 12:00 AM

Hello Sylvain,

You can send a screenshot of the revision table and that should be okay. We've had users send us screenshots by posting them on dropbox or other accessible locations - that may be a way. Or you can paste in the values into a table here in-line.  Another way is to send a developer on this thread (unfortunately I'll be out of the office tomorrow, so perhaps gdestigter) a message through codeplex, and we'll get it in our personal email. We should then be able to reply to your email and freely send files that way.

Thanks for helping us track this down!

Christine

May 3, 2012 at 6:52 AM

Hello Christine,

Before my modification my revision table was empty.

After my update, my revision table is :

Objectid : 1

osmchangeset : -1

osmaction : modify

osmelementtype : node

osmversion1

sourcefcname : test_osm_pt

osmoldid : 1692911241

osmnewid : <Nul>

osmlat : <Nul>

osmlon : <Nul>

osmstatus : <Nul>

osmstatuscode: <Nul>

osmerrormessage: <Nul>

 

I see there are some fields with <Nul> value (osmlat, osmlon), Could it be a problem ?

Thanx for your help.

 

Sylvain

Coordinator
May 14, 2012 at 8:32 PM

Hello Sylvain,

Apologies for the delay, I've been out on vacation. Thank you for sending the entry for your revision table.  The entry looks right, and the fact that there are <Nul> values should not be a problem.  After you attempt to upload this revision table, is there a value in the "osmstatus", "osmstatuscode", or "osmerrormessage" column?

Christine

May 21, 2012 at 11:54 AM

Hello Christine,

Apologies for the delay, lol, I was working on others projects and I didi'nt received the notification of your response.

There is no value in the "osmstatus", "osmstatuscode", or "osmerrormessage" column after the upload.

 

Sylvain