OSM Data download problem

Jun 29, 2011 at 3:45 PM

Hi,

I just installed the latest version of ArcGIS for OSM on ArcGIS 10 (ArcInfo) SP2.

The installation works well, but each time I tried to download OSM data with both DownloadSymbolizeOSMData tools or Download OSM Data I get the following error.

Executing: OSMGPDownload http://www.openstreetmap.org "-0.3 5.5 -0.1 5.7" DO_NOT_INCLUDE_REFERENCES E:\Temp\OSM_Mozambique.gdb\test E:\Temp\OSM_Mozambique.gdb\test\test_osm_pt E:\Temp\OSM_Mozambique.gdb\test\test_osm_ln E:\Temp\OSM_Mozambique.gdb\test\test_osm_ply
Start Time: Wed Jun 29 16:37:17 2011
Starting OSM Data download request...
Object reference not set to an instance of an object.
   at ESRI.ArcGIS.OSM.GeoProcessing.OSMGPDownload.Execute(IArray paramvalues, ITrackCancel TrackCancel, IGPEnvironmentManager envMgr, IGPMessages message)
(OSMGPDownload) aborted by User.
Failed at Wed Jun 29 16:38:59 2011 (Elapsed Time: 1 minutes 42 seconds)

I did many test on different regions with different size, but I get always the same message. :-(

If someone can help it would be very appreaciate.

Thanks in advance.

Olivier

 

Coordinator
Jun 29, 2011 at 6:16 PM

Hello Olivier,

Question to clarify... did you install the latest source code version (changeset 67351) or the 1.1 Released version (changeset 64275)?  We saw similar behavior with the 67351 version while testing and are working to resolve this issue, but haven't seen the error in the 1.1 Released version.  

Thanks!

Christine

Jun 30, 2011 at 9:07 AM

I installed the 1.1 Released version, the .exe file that is available on the Downloads Page http://esriosmeditor.codeplex.com/releases/view/64859#DownloadId=231114

Coordinator
Jun 30, 2011 at 4:54 PM

Thanks Olivier.  Follow-up question: what OS are you using, and 32 or 64 bit? I want to match your environment for our troubleshooting on this end.

Jun 30, 2011 at 6:47 PM

I use a Windows 7 64 bits. Thanks for your help.

Jul 8, 2011 at 9:36 AM

I downloaded OSM Editor on Tuesday - 5th - on advice from ESRI Support to overcome a problem with Data Interop.  I have seen a similar problem on Windows 7 64bit.  On Windows XP (32bit) I get 'Object reference not set to an instance of an object' for the same source file.  I overcame the problem by moving from Loading an osm previously downloaded to using the Download tool. 

Oct 20, 2011 at 8:23 PM

I am getting the same error with Version 1.1 on Windows 7 Ultimate, 64bit and ArcMap Info V10.0 SP1 (and without SP1, actually upgraded b/c of this problem).

 

[quote]

Messages
Executing: OSMGPFileLoader ***map.osm CONSERVE_MEMORY ****import_osm ****import_osm_osm_pt ****mport_osm_osm_ln ****import_osm\import_osm_osm_ply
Start Time: Thu Oct 20 12:15:00 2011
Preparing geodatabase...
Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
bei ESRI.ArcGIS.OSM.GeoProcessing.OSMGPFileLoader.Execute(IArray paramvalues, ITrackCancel TrackCancel, IGPEnvironmentManager envMgr, IGPMessages message)
Failed to execute (OSMGPFileLoader).
Failed at Thu Oct 20 12:15:02 2011 (Elapsed Time: 2.00 seconds)

[/quote]

I am getting this error when loading a .osm file I downloaded from the Web-API Download (tried different .osm files, all the same error).
I tried getting the osm-data through the download OSM Data tool in the toolbox, but this is giving me other errors.

Are there any other solutions for getting OSM data in ArcMap? I tried osm2shp, Osmium and other tools, but they all give me their own error reports - no way so far to import OSM to ArcGis.

Oct 20, 2011 at 8:33 PM

Ha.. found a solution (for me): it seems, that I am only getting this error when using the Load OSM... file-tool from ArcMap - using it in ArcCatalog, it works fine!

Coordinator
Oct 20, 2011 at 8:49 PM

Hello Helmut, thanks for sharing the error and your workaround. Is it possible to provide a link to the OSM file so we can replicate? I am curious as to why it worked in ArcCatalog but not ArcMap.

Christine

Oct 20, 2011 at 9:12 PM

It does not seem to be related to the .osm file - no osm file I tried worked. I guess [but can be wrong], it has something to do with my Workspace setup of ArcGis like file accessebility, read and write rights and these things..

But feel free to look at one of the .osm files I was using (downloaded via web):

https://www.wetransfer.com/dl/iY5pu8gX/c68617eebac557334dcc1eba7d475ea53a2bb7d4770fad9deecc7e6a46f423f475e03d8616f4d0d

 

Coordinator
Oct 20, 2011 at 9:19 PM

Thanks Helmut. We'll take a look... you could be right about the Workspace setup, and if that is the case we want to add that to the documentation (or resolve some other way).

 

Christine

Coordinator
Oct 22, 2011 at 1:13 AM

Hello Helmut,

I was able to Load your osm file in both a Windows XP and Windows 7 64 bit ArcMap environment.  I'm wondering if you run ArcMap as an Administrator (right-click on the ArcMap icon in the Program menu, and select the Run as Administrator option) if that makes a difference?

Christine