Uploads fail

Jun 2, 2011 at 9:09 AM

I modified some polygons (cut and deleted one part, merged a couple) and altered boundaries of polygons. Plus I moved some vertices of roads.

After saving the modifications, I tried to upload the data, but without success. I then checked the data in Potlach, and saw that my modifications had come through, but without deleting the old vertices of the removed/changed parts.

I don't know what the problem is, but it seems like the editor does not completely delete all old vertices, resulting in errors. Anyone found the same issue, and knows a way to solve this?

I would really like to use ArcMap, but when I, after uploading, have to use JOSM or Potlach to solve all errors, using ArcMap makes no sense.

 

BTW. I also posted an issue like this a couple of weeks ago in the issuelist, but had no response yet.

Thanks, Koen

Coordinator
Jun 2, 2011 at 11:46 PM

Thanks for bringing this to our attention Koen, and apologies that we didn't respond sooner on the corresponding issue you logged. We are looking at it now, and hopefully will have an answer for you soon...

Coordinator
Jun 6, 2011 at 6:29 PM

Hello Koen,

I was able to replicate the behavior - got the same error, and like you was not able to delete old vertices.  I will check with our dev team to see if there is a workaround; otherwise, we will update the issue #8740 you logged. 

Jun 6, 2011 at 8:06 PM

Hi there,

good to hear that you were able to replicate the error. Good luck finding a solution and thanks for working on it.

Cheers, Koen

Oct 2, 2011 at 8:39 AM

Hi!

Is this issue present in version 2.0 beta?

Thanks, Oleg

Coordinator
Oct 3, 2011 at 3:49 PM

I will check on this and get an answer for you this afternoon.  There is a known issue with Upload to OSM failing with the Version 2.0 Beta, but that is different that this behavior.

Coordinator
Nov 22, 2011 at 6:40 PM

An update on this thread... this should be fixed in our upcoming version 2 release, and you will see it in beta 2. We are planning to release beta 2 within the next few days, and would appreciate feedback you have concerning this feature and fix.

Christine