Invalid Tool - Unable to execute the selected tool

Apr 29, 2011 at 1:02 AM

Everything appears to have been installed successfully but when viewing the toolbox about half of the tools have a little red x over their icon. When I click on any of the tools in the toolbox I get the error "Invalid Tool - Unable to execute the selected tool". Tried reinstalling but no luck.

I've installed version 1.1 and am running ArcMap 10.0 with a concurrent ArcInfo license on Windows 7.

Developer
Apr 29, 2011 at 1:08 PM

Do you get the red X over the models or the tools?

Some models have changed and due to the changes in parameters toolboxes from version 1.0 to 1.1 might appear broken. Please take the toolbox from the installation directory (and the data subfolder). Licensing should not be an issue as the tool are supposed to work ArcView and up.

- Thomas 

Apr 29, 2011 at 3:17 PM

Good morning Thomas, thanks  for your quick reply!

When you say "take the toolbox from the installation directory (and the data subfolder)", what do you mean? I created a new directory for my mxd and default geodatabase as instructed in the documentation, copied the data folder into it and ran the toolbox from there but it made no difference.

The following tools (and models) have a red X when the toolbox is first opened: Combine Layers, Download and Symbolize OSM Data, Download OSM Data, Symbolize Lines, Symbolize OSM Data, Symbolize Points and Symbolize Polygons. The other tools look normal until I try to run them, then the red X appears on those too.

Thanks!

Jill

Developer
Apr 29, 2011 at 3:46 PM

Jill,

yes, that's what  I meant with the copy and paste of the data folder content. Would you happen to have an already existing OSM geodatabase from a previous version of the tool? I would like to find out if the editor is respecting the existing OSM data and showing you the custom feature inspector to handle the OSM tags and keys.

From what you have described so far, it does sound like an error in the installation routine.

- Thomas 

Apr 29, 2011 at 3:55 PM

Thomas,

This is the first time I've installed this tool or ever tried to edit OSM data so I don't have any existing data that could be causing a conflict.

Thanks!

Developer
Apr 29, 2011 at 5:27 PM

Jill,

I've opened an issue at http://esriosmeditor.codeplex.com/workitem/8726. Please download the attachment and see if you can open the datasets (the feature classes inside the redlands datatset) on your machine. If you get an error message instead then something fundamental didn't happen in the installation process.

- Thomas

Apr 29, 2011 at 6:28 PM

Thomas,

When I try and view the three feature classes inside the Redlands dataset I get the error, "Error opening feature class. Unable to create object class extension COM component"

Thanks

Developer
May 3, 2011 at 4:57 PM

Jill,

what it comes down to is that the install didn't complete. Did you run the setup file as an administrator? Or in other words on your Windows7 machine did the user access control ask you for administrator privileges as you double-clicked the setup file?

 

May 3, 2011 at 5:07 PM

Hi Thomas,

I did the install as the administrator (uninstalled/reinstalled it just to be sure) and got no request for additional privileges when I ran the setup file.

Thanks!