Download to Different Schema

Apr 1, 2011 at 11:04 PM

I want to use a different schema when downloading points from OSM. I've been attempting this by creating a geodatabase that has a feature dataset containing a points feature class that has an empty table to use as a template with the already created schema. It worked for me the first time and hasn't since. I thought maybe it was locked somewhere but have checked the usual places and it is not. I've also uninstalled and reinstalled OSMEditor. I've tried creating a points layer from the points feature class and substituting it in the OSM Group Layer, but that hasn't worked either. What is the best way to approach this? Thanks!

Apr 4, 2011 at 6:28 AM

Could you please go into a little more detail why you are interested in a custom schema?

The feature classes as they are created right know contain the minimum of expected fields. I don't think I have tried changing the schema and then attempting loading into the modified schema. It should work but you might find yourself in a situation where the original OSM data is lost as expected fields to store the data are missing. Are you getting any error messages?

- Thomas

Apr 5, 2011 at 5:00 PM

I am working on a collaboration prototype that uses OpenStreetMap as the base for a volunteer geographic information structures project. The structures data we are collecting has a different schema than OpenStreetMap. I want to be able to use the OpenStreetMap Editor tool to download the structures information into a schema that has our specific schema structures, instead of the OpenStreetMap default feature classes.

When I run the Download OSM Data tool with the substituted Points Layer I created, the Results Messages say:

Starting OSM Data download request...

Object reference not set to an instance of an object.

    at ESRI.ArcGIS.OSM.GeoProcessing.OSMGPDownload.Execute(Iarray paramvalues, ItrackCancel TrackCancel, IGPEnvironmentManager envMgr, IGPMessages message)

(OSMGPDownload) aborted by User.

If I run the tool with the original Points Layer in tact, with the download being saved into the geodatabase that has the schema I want, it only downloads the original OSM default schema (except for the first time I tried, as I've stated before). I've only been focusing on the points because that is what the structures data are. Thanks!


Apr 6, 2011 at 6:32 AM


I think you have to download it into the default data schema and consider that your staging database. From there you can extract the tags into attributes with the OSM Attribute Selector tool. Once that is done you can either use the Copy features or Append features tool with the attribute mapping to fit into the schema of your choice.

- Thomas