Installation

Jul 20, 2010 at 2:49 PM
I downloaded the beta and installed it on a Windows 7 computer running ArcGIS 10 (arcview) single use license. The software appears to install without error. But when I open the toolbox, I do not see the OSM Editor tools. In ArcMAP I can "customize -> Toolbars ->OpenStreetMap" and I get a floating toolbar with a disabled "OSM Conflict Editor" button. Do I need to do anything else to get this to work? By the way, I think the idea of providing a solid editor for OSM is an incredible idea! Given that MapQuest recently launch a site using OSM, it may drive the need for better editing software (by the way, I worked at MQ for 10 years before going out on my own).
Aug 23, 2010 at 9:34 PM

I downloaded the beta 2 and installed it on a Windows XP computer running ArcGIS 9.2 (ArcInfo) single use licencse.  The installation end but with many "Error opening file for writing: \help\gp\osmgpaddextension.xml" and others files.  When I open the toolboox I do not see the Open Street Map Tools. I try to install adding a toolbox "OpenStreetMap Toolbox.tbx" that I found in data directory but nothing happened. I need to upgrade my ArcGIS version to the last to test this program.  I hope it works. 

Sep 24, 2010 at 2:28 PM
Edited Sep 24, 2010 at 2:29 PM

@ johnfix

goto Toolbox -> right click "add Toolbox" -> browse to the install location ( <install drive>:\Program Files\ESRI\ArcGIS Editor for OpenStreetMap) and ad the *.tbx file

 

rock on!

Sep 27, 2010 at 7:23 PM
Edited Sep 27, 2010 at 7:25 PM

I downloaded the current release and installed it (had to remove the beta 1st). I then followed your instructions, everything worked fine.

I did download a piece of OSM data, used the tools to symbolize it, and then tried to add a building polygons. Seems a little funky to use. But then I’m not use to ArcGIS10’s new editing interface. After I saved my edits and tried to upload to OSM, my 3 new polygons disappears. So, I guess I’ll skim the documents to see if I missed a step.

Thank neonjesus.

-John